package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w*[a-zA-Z]\w*)`)
var str = `abcde
a012ds
adas31
1313a
a3141
a
313141`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}