$re = '/\/\*[\s\S]*?\*\/|(?<=[^:])\/\/.*|^\/\/.*/m';
$str = '// other comment
//test
here /*test*/
alert(\'hello, this code has comments!\')//An alert
/* A block comment here */
// A single line comment on a newline
/*
multiple lines*/
/** double asterisks */
//
some text
/**/
/*
* multiple lines again
*/
some text
/* here / there */
var url="https://www.website.com";//comment';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);