const regex = /^(?![0-9])[a-zA-Z0-9$_]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?![0-9])[a-zA-Z0-9$_]+$', 'gm')
const str = `newName
newName32
_newName
4newName
new Name
"") `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}