re = /^(?![0-9])[a-zA-Z0-9$_]+$/m
str = 'newName
newName32
_newName
4newName
new Name
"") '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end