$re = '/^(?![0-9])[a-zA-Z0-9$_]+$/m';
$str = 'newName
newName32
_newName
4newName
new Name
"") ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);