using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<mrow[^>]*>\(?((?:(?!</?mrow\b[^>]*>).)*?)\)?</mrow>";
string input = @"<msub><mi>y</mi><mrow>(<mi>n</mi><mo>+</mo><mn>1</mn>)</mrow></msub><mo>=</mo><msub><mi>y</mi><mrow>(<mi>n</mi><mo>-</mo><mn>1</mn>)</mrow></msub><mo>*</mo><msup><mrow>(<msub><mi>y</mi><mi>n()</mi></msub>)</mrow><mrow><mn>2</mn></mrow></msup>
<mrow>(<mn>1000001</mn>)</mrow>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}