package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)DATE: (?P<date>[\s\S]+)\nSTAGE: (?P<stage>[\s\S]+)\nSCORE: (?P<score>[\s\S]+)\nNAME: (?P<name>[\s\S]+)\nHOBBY: (?P<hobby>[\s\S]+?)\n(?:AGE: )?(?P<age>[\s\S]*?)(\n)?NOTES:(?P<notes>[\s\S]+)`)
var str = `DATE: 2/3/21 10:23:42 AM CST
STAGE: 1
SCORE: 2,321
NAME: Sally
HOBBY: Swimming
AGE: 26
NOTES: But she doesn't like: sun, fish
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}