import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "DATE: (?P<date>[\\s\\S]+)\\nSTAGE: (?P<stage>[\\s\\S]+)\\nSCORE: (?P<score>[\\s\\S]+)\\nNAME: (?P<name>[\\s\\S]+)\\nHOBBY: (?P<hobby>[\\s\\S]+?)\\n(?:AGE: )?(?P<age>[\\s\\S]*?)(\\n)?NOTES:(?P<notes>[\\s\\S]+)";
final String string = "DATE: 2/3/21 10:23:42 AM CST\n"
+ "STAGE: 1\n"
+ "SCORE: 2,321\n"
+ "NAME: Sally\n"
+ "HOBBY: Swimming\n"
+ "AGE: 26\n"
+ "NOTES: But she doesn't like: sun, fish\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}