const regex = /DATE: (?P<date>[\s\S]+)\nSTAGE: (?P<stage>[\s\S]+)\nSCORE: (?P<score>[\s\S]+)\nNAME: (?P<name>[\s\S]+)\nHOBBY: (?P<hobby>[\s\S]+?)\n(?:AGE: )?(?P<age>[\s\S]*?)(\n)?NOTES:(?P<notes>[\s\S]+)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('DATE: (?P<date>[\\s\\S]+)\\nSTAGE: (?P<stage>[\\s\\S]+)\\nSCORE: (?P<score>[\\s\\S]+)\\nNAME: (?P<name>[\\s\\S]+)\\nHOBBY: (?P<hobby>[\\s\\S]+?)\\n(?:AGE: )?(?P<age>[\\s\\S]*?)(\\n)?NOTES:(?P<notes>[\\s\\S]+)', 'mg')
const str = `DATE: 2/3/21 10:23:42 AM CST
STAGE: 1
SCORE: 2,321
NAME: Sally
HOBBY: Swimming
AGE: 26
NOTES: But she doesn't like: sun, fish
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}