#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:|(https?:\/\/)?(|www)[.]?((t|telegram)\.me)\/joinchat\/)[a-zA-Z0-9_]{5,32}$"
Local $sString = "https://www.t.me/joinchat/I5antRHvea8ohaU7_RsYYQ" & @CRLF & _
"https://www.telegram.me/joinchat/I5antRHvea8ohaU7_RsYYQ" & @CRLF & _
"http://t.me/joinchat/I5antRHvea8ohaU7_RsYYQ" & @CRLF & _
"http://telegram.me/joinchat/I5antRHvea8ohaU7_RsYYQ" & @CRLF & _
"www.t.me/joinchat/I5antRHvea8ohaU7_RsYYQ" & @CRLF & _
"www.telegram.me/joinchat/I5antRHvea8ohaU7_RsYYQ" & @CRLF & _
"t.me/joinchat/I5antRHvea8ohaU7_RsYYQ" & @CRLF & _
"telegram.me/joinchat/I5antRHvea8ohaU7_RsYYQ"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")