import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:|(https?:\\/\\/)?(|www)[.]?((t|telegram)\\.me)\\/joinchat\\/)[a-zA-Z0-9_]{5,32}$";
final String string = "https://www.t.me/joinchat/I5antRHvea8ohaU7_RsYYQ\n"
+ "https://www.telegram.me/joinchat/I5antRHvea8ohaU7_RsYYQ\n"
+ "http://t.me/joinchat/I5antRHvea8ohaU7_RsYYQ\n"
+ "http://telegram.me/joinchat/I5antRHvea8ohaU7_RsYYQ\n"
+ "www.t.me/joinchat/I5antRHvea8ohaU7_RsYYQ\n"
+ "www.telegram.me/joinchat/I5antRHvea8ohaU7_RsYYQ\n"
+ "t.me/joinchat/I5antRHvea8ohaU7_RsYYQ\n"
+ "telegram.me/joinchat/I5antRHvea8ohaU7_RsYYQ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}