import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https?:\\/\\/)((?:[-a-zA-Z0-9@:%._+~#=]+)\\.)?([-a-zA-Z0-9@:%._+~#=]{2,256}\\.[a-z]{2,6}\\b|localhost(?:\\:\\d{1,5})?)(\\/[\\w.-]*)*(\\?[\\w\\-._~!*'(),%=&+]*)?($|\\#.*|\\?.*)?";
final String string = "https://www.google.com/search?q=define+inherently&oq=&gs_lcrp=EgZjaHJvbWUqBggCEEUYOzIGCAAQRRg5Mg4IARBFGCcYOxiABBiKBTIGCAIQRRg7Mg8IAxAAGEMYyQMYgAQYigUyDAgEEAAYQxiABBiKBTIMCAUQABhDGIAEGIoFMg0IBhAAGJIDGIAEGIoFMg0IBxAAGJIDGIAEGIoFMgcICBAAGIAEMgcICRAAGI8C0gEJNjY1MGowajE1qAIAsAIA&sourceid=chrome&ie=UTF-8#shebang";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}