import re
regex = re.compile(r"(https?:\/\/)((?:[-a-zA-Z0-9@:%._+~#=]+)\.)?([-a-zA-Z0-9@:%._+~#=]{2,256}\.[a-z]{2,6}\b|localhost(?:\:\d{1,5})?)(\/[\w.-]*)*(\?[\w\-._~!*'(),%=&+]*)?($|\#.*|\?.*)?", flags=re.MULTILINE)
test_str = "https://www.google.com/search?q=define+inherently&oq=&gs_lcrp=EgZjaHJvbWUqBggCEEUYOzIGCAAQRRg5Mg4IARBFGCcYOxiABBiKBTIGCAIQRRg7Mg8IAxAAGEMYyQMYgAQYigUyDAgEEAAYQxiABBiKBTIMCAUQABhDGIAEGIoFMg0IBhAAGJIDGIAEGIoFMg0IBxAAGJIDGIAEGIoFMgcICBAAGIAEMgcICRAAGI8C0gEJNjY1MGowajE1qAIAsAIA&sourceid=chrome&ie=UTF-8#shebang"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")