use strict;
my $str = 'https://www.google.com/search?q=define+inherently&oq=&gs_lcrp=EgZjaHJvbWUqBggCEEUYOzIGCAAQRRg5Mg4IARBFGCcYOxiABBiKBTIGCAIQRRg7Mg8IAxAAGEMYyQMYgAQYigUyDAgEEAAYQxiABBiKBTIMCAUQABhDGIAEGIoFMg0IBhAAGJIDGIAEGIoFMg0IBxAAGJIDGIAEGIoFMgcICBAAGIAEMgcICRAAGI8C0gEJNjY1MGowajE1qAIAsAIA&sourceid=chrome&ie=UTF-8#shebang';
my $regex = qr/(https?:\/\/)((?:[-a-zA-Z0-9@:%._+~#=]+)\.)?([-a-zA-Z0-9@:%._+~#=]{2,256}\.[a-z]{2,6}\b|localhost(?:\:\d{1,5})?)(\/[\w.-]*)*(\?[\w\-._~!*'(),%=&+]*)?($|\#.*|\?.*)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}