const regex = /([\w\s]*(?:\([^)]*\)[\w\s]*)*)([*?$&])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\w\\s]*(?:\\([^)]*\\)[\\w\\s]*)*)([*?$&])', 'g')
const str = `Foo (.*) bar blla (.*) b*l?a\$ && bla bla\\r\\n`;
const subst = `$1\\$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);