use strict;
my $str = 'Foo (.*) bar blla (.*) b*l?a$ && bla bla\\r\\n';
my $regex = qr/([\w\s]*(?:\([^)]*\)[\w\s]*)*)([*?$&])/p;
my $subst = '$1\\\\$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";