$re = '/([\w\s]*(?:\([^)]*\)[\w\s]*)*)([*?$&])/';
$str = 'Foo (.*) bar blla (.*) b*l?a$ && bla bla\\r\\n';
$subst = "$1\\$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;