re = /^(1)?([.\-\ ])?(\()?(\d{3})?(\))?([.\-\ ])?(\d{3})?([.\-\ ])?(\d{4})?$/i
str = '15095315910'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end