using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<major>\d+)\.(?P<minor>\d+)\.(?P<patch>\d+)\.?(?P<pre_release>\d*)(?P<build>\S*)";
string input = @"1.2.3.4-ASDF
1.2.3.2389+eiersalat
102.18.31.00064.lmao
1.0.3.1664888532357316300
1.0.3.1664888532357316300
22.6.0-old
123.456.789-o2341
123.456.788.asef
1.2.3
1.2.3.4";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}