import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<major>\\d+)\\.(?P<minor>\\d+)\\.(?P<patch>\\d+)\\.?(?P<pre_release>\\d*)(?P<build>\\S*)";
final String string = "1.2.3.4-ASDF\n"
+ "1.2.3.2389+eiersalat\n"
+ "102.18.31.00064.lmao\n"
+ "1.0.3.1664888532357316300\n"
+ "1.0.3.1664888532357316300\n"
+ "22.6.0-old\n"
+ "123.456.789-o2341\n"
+ "123.456.788.asef\n"
+ "1.2.3\n"
+ "1.2.3.4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}