use strict;
my $str = '1.2.3.4-ASDF
1.2.3.2389+eiersalat
102.18.31.00064.lmao
1.0.3.1664888532357316300
1.0.3.1664888532357316300
22.6.0-old
123.456.789-o2341
123.456.788.asef
1.2.3
1.2.3.4';
my $regex = qr`(?P<major>\d+)\.(?P<minor>\d+)\.(?P<patch>\d+)\.?(?P<pre_release>\d*)(?P<build>\S*)`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}