import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<sexe>[1-478])\\s*?(?<annee>[0-9]{2})\\s*?(?<mois>0[1-9]|1[0-2]|[2-3][0-9]|4[0-2]|[5-9][0-9])\\s*?(?<departement>2[ABab]|[0-9]{2}|9[7-8][0-9])\\s*?(?<commune>[0-9]{3}|[0-9]{2})\\s*?(?<ordre>00[1-9]|0[1-9][0-9]|[1-9][0-9]{2})\\s*?(?<cle>0[1-9]|[1-8][0-9]|9[0-7])\\s*?$";
final String string = "100089932132111\n"
+ "2 80 05 17 001 001 01\n\n"
+ "Cas Spécifiques définis ici : https://fr.wikipedia.org/wiki/Num%C3%A9ro_de_s%C3%A9curit%C3%A9_sociale_en_France\n"
+ "=> Naissance à l'étranger en cours d'immatriculation en France avec mois de naissance pseudo-fictif (état-civil incomplet)\n"
+ "8 00 31 99 901 001 02\n\n"
+ "=> Naissance en Outre-Mer\n"
+ "2 00 01 987 01 001 02";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}