// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<sexe>[1-478])\s*?(?<annee>[0-9]{2})\s*?(?<mois>0[1-9]|1[0-2]|[2-3][0-9]|4[0-2]|[5-9][0-9])\s*?(?<departement>2[ABab]|[0-9]{2}|9[7-8][0-9])\s*?(?<commune>[0-9]{3}|[0-9]{2})\s*?(?<ordre>00[1-9]|0[1-9][0-9]|[1-9][0-9]{2})\s*?(?<cle>0[1-9]|[1-8][0-9]|9[0-7])\s*?$").unwrap();
let string = "100089932132111
2 80 05 17 001 001 01
Cas Spécifiques définis ici : https://fr.wikipedia.org/wiki/Num%C3%A9ro_de_s%C3%A9curit%C3%A9_sociale_en_France
=> Naissance à l'étranger en cours d'immatriculation en France avec mois de naissance pseudo-fictif (état-civil incomplet)
8 00 31 99 901 001 02
=> Naissance en Outre-Mer
2 00 01 987 01 001 02";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}