package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+)([rp]\d{4,})(.*?)\s+((?:[A-Z]\w+,\s+)+)`)
var str = `04040p0015 Macro drive object / Macro DO SERVO, VECTOR, HLA, SERVO_AC, VECTOR_AC, SERVO_I_AC, VECTOR_I_AC, A_INF, S_INF, R_INF, B_INF, TM31, TM15DI_DO, TM120, TM150, p0015Macro drive object / Macro DO SERVO, VECTOR, HLA, SERVO_AC, VECTOR_AC, SERVO`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}