re = /(\d+)([rp]\d{4,})(.*?)\s+((?:[A-Z]\w+,\s+)+)/m
str = '04040p0015 Macro drive object / Macro DO SERVO, VECTOR, HLA, SERVO_AC, VECTOR_AC, SERVO_I_AC, VECTOR_I_AC, A_INF, S_INF, R_INF, B_INF, TM31, TM15DI_DO, TM120, TM150, p0015Macro drive object / Macro DO SERVO, VECTOR, HLA, SERVO_AC, VECTOR_AC, SERVO'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end