#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[^\r\n]+(?:\r?\n(?!\s*[a-z][)])[^\r\n]*)*"
Local $sString = "Os Embargos de Terceiros fazem parte do procedimento especial, previsto no Código de Processo Civil, sendo possível sua utilização por quem, não sendo parte no processo, sofre constrição ou sofre ameaça de constrição sobre bens que possua ou sobre os quais tenha direito incompatível com o ato constritivo. Sobre o ajuizamento dos embargos, assinale a alternativa INCORRETA." & @CRLF & _
"" & @CRLF & _
"Considere o segmento “[...] o Estado só percebe o eco enfraquecido.†(2º§). Pode-se afirmar que a partir do recurso de linguagem utilizado pelo enunciador na escolha da palavra “Estadoâ€, identifica-se 7" & @CRLF & _
"" & @CRLF & _
"a) o estabelecimento de uma comparação entre “Estado†e “governantesâ€." & @CRLF & _
"b) o emprego de uma palavra redundante objetivando reforçar a ideia expressa." & @CRLF & _
" questões que irão ter várias quebra de linhas" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" questões que irão ter várias quebra de linhas" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"c) uma transferência de percepções resultando em uma fusão de impressões sensoriais." & @CRLF & _
"d) a evocação de um termo em lugar de uma palavra, com a qual se acha relacionada não sendo sinônimos. "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")