#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)uniprotkb:(.*?)[-(][a-zA-Z]"
Local $sString = "uniprotkb:P62158(protein(MI:0326), 9606 - Homo sapiens)" & @CRLF & _
"uniprotkb:O00602-PRO_0000009136(protein(MI:0326), 9606 - Homo sapiens)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")