package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)uniprotkb:(.*?)[-(][a-zA-Z]`)
var str = `uniprotkb:P62158(protein(MI:0326), 9606 - Homo sapiens)
uniprotkb:O00602-PRO_0000009136(protein(MI:0326), 9606 - Homo sapiens)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}