re = /uniprotkb:(.*?)[-(][a-zA-Z]/m
str = 'uniprotkb:P62158(protein(MI:0326), 9606 - Homo sapiens)
uniprotkb:O00602-PRO_0000009136(protein(MI:0326), 9606 - Homo sapiens)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end