const regex = /^(?=.*\d)(?=.*[a-zA-Z])[a-zA-Z\d]{6}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*\\d)(?=.*[a-zA-Z])[a-zA-Z\\d]{6}$', 'gm')
const str = `q295zp
gd5z9r
ktsft5
mz3jr4
abcd12464`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}