$re = '/^(?=.*\d)(?=.*[a-zA-Z])[a-zA-Z\d]{6}$/m';
$str = 'q295zp
gd5z9r
ktsft5
mz3jr4
abcd12464';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);