re = /^(?=.*\d)(?=.*[a-zA-Z])[a-zA-Z\d]{6}$/m
str = 'q295zp
gd5z9r
ktsft5
mz3jr4
abcd12464'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end