use strict;
my $str = '4711_001.doc';
my $regex = qr/[^_.]*\K_[^._]+(?=\.[^.]+$)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";