$re = '/[^_.]*\K_[^._]+(?=\.[^.]+$)/m';
$str = '4711_001.doc';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;