package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*?\+`)
var str = `xxxaaa123456789::9beliebige (Sonder-)Zeichen :?ßÜö%$§+Weiterer Text, der unwichtig ist!+und weiter gehts`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}