re = /.*?\+/m
str = 'xxxaaa123456789::9beliebige (Sonder-)Zeichen :?ßÜö%$§+Weiterer Text, der unwichtig ist!+und weiter gehts'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end