$re = '/.*?\+/m';
$str = 'xxxaaa123456789::9beliebige (Sonder-)Zeichen :?ßÜö%$§+Weiterer Text, der unwichtig ist!+und weiter gehts';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);