package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+)\s*?x\s*?(\d+,\d+)\s*?(\d+,\d+)(\w)`)
var str = `nak 1 x 12,00 12,00B dowolny znak`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}