$re = '/(\d+)\s*?x\s*?(\d+,\d+)\s*?(\d+,\d+)(\w)/m';
$str = 'nak 1 x 12,00 12,00B dowolny znak';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);