const regex = /(\d+)\s*?x\s*?(\d+,\d+)\s*?(\d+,\d+)(\w)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)\\s*?x\\s*?(\\d+,\\d+)\\s*?(\\d+,\\d+)(\\w)', 'gm')
const str = `nak 1 x 12,00 12,00B dowolny znak`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}