use strict;
my $str = 'UPDATE `wp_options` SET `option_value` = \'a:1151:{s:15:\\"activ";}\' WHERE `option_name` = \'my_options\';
INSERT INTO Customers (CustomerName, ContactName, Address, City, PostalCode, Country)
VALUES (\'Cardinal\', \'Tom B. Erichsen\', \'Skagen 21\', \'Stavanger\', \'4006\', \'Norway\');';
my $regex = qr/(["'])(?:(?=(\\?))\2.)*?\1/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}