$re = '/(["\'])(?:(?=(\\\\?))\2.)*?\1/m';
$str = 'UPDATE `wp_options` SET `option_value` = \'a:1151:{s:15:\\"activ";}\' WHERE `option_name` = \'my_options\';
INSERT INTO Customers (CustomerName, ContactName, Address, City, PostalCode, Country)
VALUES (\'Cardinal\', \'Tom B. Erichsen\', \'Skagen 21\', \'Stavanger\', \'4006\', \'Norway\');';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);