$re = '/([^\?#]*\w)((?:/#|#)?)([^\?]*)($|\?.*)/is';
$str = 'https://demo.wofll.com/#/demo?a=1&b=2';
$subst = "$1/index.html$2$3$4";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;