import re
regex = re.compile(r"([^\?#]*\w)((?:/#|#)?)([^\?]*)($|\?.*)", flags=re.IGNORECASE | re.DOTALL)
test_str = "https://demo.wofll.com/#/demo?a=1&b=2"
subst = "$1/index.html$2$3$4"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)