const regex = /test(?!.*test(?=.*test))(?=.*XX12QW).+(?=test)/gsm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('test(?!.*test(?=.*test))(?=.*XX12QW).+(?=test)', 'gsm')
const str = `test
abc def
test 123
test pqr
XX12QW
jkl XX12QW hjas
12asd23 test bxs`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}