$re = '/test(?!.*test(?=.*test))(?=.*XX12QW).+(?=test)/sm';
$str = 'test
abc def
test 123
test pqr
XX12QW
jkl XX12QW hjas
12asd23 test bxs';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);