re = /test(?!.*test(?=.*test))(?=.*XX12QW).+(?=test)/m
str = 'test
abc def
test 123
test pqr
XX12QW
jkl XX12QW hjas
12asd23 test bxs'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end