package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([jJ][aA][cC][kK]\s[cC][aA][rR][tT][eE][rR]|[jJ][aA][cC][kK]\s[aA-zZ]\s[cC][aA][rR][tT][eE][rR]|[jJ][aA][cC][kK]\s[aA-zZ][.]\s[cC][aA][rR][tT][eE][rR])`)
var str = `Jack Carter
Jack C Carter
Jack Z. Carter
JAck Carter
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}