package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([\w.-]+)=([A-Za-z0-9.-]+):(\d+)$`)
var str = `minecraft.local=minecraft-java.ix-minecraft-java.svc.cluster.local:25565`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}