re = /^([\w.-]+)=([A-Za-z0-9.-]+):(\d+)$/m
str = 'minecraft.local=minecraft-java.ix-minecraft-java.svc.cluster.local:25565'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end